Help! My camera won't turn on!

We have a Canon t2i and for some reason it's not turning on. The batteries are fully charged but I tried turning it on I got nothing! Any ideas on what it might be and how to fix it???

Posted on August 14, 2011 at 2:32 am
Melly1588
5
01/23/2010
Melly1588

Melly1588

  • 5
  • 14
  • 9.06k
327
Followers
330
Following

(2) Comments

BelgianInAustralia
3
04/15/2011
BelgianInAustralia

BelgianInAustralia

  • 3
  • 9
  • 1.18k
297
Followers
301
Following

BelgianInAustralia

Only time I've ever encountered that the problem was faulty batteries (different brand camera thou). So I would suggest make 100% sure your battery are fully charged. Do you have 2 sets of batteries so you can swap?


If it's not that, go have it checked out.

Posted on August 14, 2011 at 5:51 pm
doolittlebride
4
10/03/2010
doolittlebride

doolittlebride

  • 4
  • 12
  • 3.61k
126
Followers
129
Following

doolittlebride

This is a good reason to have back up batteries.  I, too, think it might be the battery.


When this happens, you want to take the entire camera apart (the consumer parts) - the lense, battery, card - remove it all and let it sit for a while  (several minutes).  Insert the new battery, card, and reattach the lens.  It should come back on.  If it doesn't, you may have damaged it with the battery.


While I've not heard of the nickel-cad batteries damaging a camera, anything is possible.

Posted on August 15, 2011 at 5:52 am

Top Contributors this Week
jmbuss9
20 posts
Kuppy13
15 posts
NicoleJuliette
14 posts
LauraSweet
12 posts
Uhlease
11 posts
KimandByron
7 posts